Стр.2 2.2. Создание формулы с функциями

Создание условных формул

Скрыть все

Действия по проверке истинности условий и логическому сравнению выражений применяются во многих задачах. Для создания условных формул используются функции И, ИЛИ, НЕ и ЕСЛИ.

Структура функции ЕСЛИ имеет вид

=ЕСЛИ (логическое выражение; значение, если истина; значение, если ложь).

Формула с функцией ЕСЛИиспользует следующие аргументы:

Логическое выражение: условие, которое требуется проверить;

Значение, если истина: значение, возвращаемое, если условие истинно;

Значение, если ложь: значение, возвращаемое, если условие ложно. Функция ЕСЛИ используется при проверке условий для значений и формул.На рис.1 приведен пример создания условной формулы .

Рис.1

В качестве значений аргументов для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ.

Если один из аргументов функции ЕСЛИ является массивом , при выполнении функции ЕСЛИ вычисляются все элементы массива.

.

ФОРМУЛЫ ОПИСАНИЕ и РЕЗУЛЬТАТ
=ЕСЛИ(A2=9; "ОК"; "Ошибка") Если значение в ячейке A2 равно 9, возвращается "ОК" иначе "Ошибка". Результат (ОК)
=ЕСЛИ(A29; "ОК"; "Ошибка") Если значение в ячейке A2 не равно 9, возвращается "ОК"" иначе "Ошибка" Результат (Ошибка)
=ЕСЛИ(НЕ(A2<=15);"ОК"; "Ошибка") Если значение в ячейке A2 не меньше и не равно 15, возвращается "ОК" иначе "Ошибка".Результат (Ошибка)
=ЕСЛИ(A5"Да "; "ОК"; "Ошибка") Если значение в ячейке A4 не равно "Да", возвращается "ОК" иначе "Ошибка". Результат (Ошибка)
=ЕСЛИ(И(A2>A3;A2 Если 9 больше 8 и меньше 14, возвращается "ОК"" иначе "Ошибка". Результат (ОК)
=ЕСЛИ(И(A2A3; A2A4); "ОК"; "Ошибка") Если 9 не равно 8 и не равно 14, возвращается "ОК". Результат (ОК)
=ЕСЛИ(ИЛИ(A2>A3; A2 Если 9 больше 8 или меньше 14, возвращается "ОК"." иначе "Ошибка". Результат (ОК)
=ЕСЛИ(ИЛИ(A5"Нет"; A6"Да"); "ОК"; "Ошибка") Если значение в ячейке A5 не равно "Нет" или значение в ячейке A6 не равно "Да", возвращается "ОК" иначе "Ошибка".Результат (ОК).

Стр.2 2.2. Создание формулы с функциями

●ЛКМ по ячейке, в которую требуется ввести формулу →Вкладка формулы→ кнопка Вставить функцию → Выберите необходимую функцию→Введите аргументы → Enter.

ПРИМЕР 1. Составление таблицы значений функции A*X^2+B*X+D(табл.1)

●ЛКМ по объединяемым ячейкам А1:С2→Формат ячеек→Выравнивание→Объединение ячеек→ОК→ Запишите текст в А1:С2.

● Запишите текст в А3:С3.

●Переименуйте ; ячейку А4 в А; ячейку В4 в В; ячейку С4 в D

●В ячейки А4:D4 введите соответствующие значения.

●А6:С6 заполните заголовками столбцов.

●Форматируете А7В12 как числовой с двумя знаками после запятой.

●В ячейку А7 Запишите начальное значение Х1= -1,25

●В ячейку →ЛКМ протащите до А12 можно и дальше.

●В ячейку →ЛКМ протащите до В12 можно и дальше.

ПРИМЕР 2. Заполнить табл.2, используя информацию табл.2 и ниже следующие формулы строк.

Самостоятельно добавить к табл.2 проверку при Х1 и Х2.

ПРИМЕР 3. Заполнить табл.3,используя информацию табл.3 и Функции SIN и COS обратите внимание как будет выглядеть формула Рис. 1.

Рис.1


6096795573336267.html
6096907755607777.html
    PR.RU™